Ubuntu – How to install libboost_version1.59 or newer on Ubuntu16.04

ccompilinglibraries

How can I install libboost1.59 ?

I have tried many methods to install it, but fail to update the version 1.58 on my Ubuntu 16.04 to the version 1.59.

I tried this and this on StackOverflow, this on linuxfromscratch.org and this blog post

Who can give me an effective method?

Best Answer

  • To get the latest go here, then:

    1. download and extract with tar -xf boost_X_XX_X.tar.gz where XX is the version number, like tar -xf boost_1_62_0.tar.gz
    2. cd boost_X_XX_X
    3. get required libraries:

      sudo apt-get update && sudo apt-get install build-essential g++ python-dev autotools-dev libicu-dev build-essential libbz2-dev libboost-all-dev
      
    4. build with ./bootstrap.sh --prefix=/usr/local

    5. install with sudo ./b2 install

    Please note you can also get the version currently on your version of Ubuntu can be gotten here

  • Related Question