Ubuntu – How to install screem

compilingsoftware installation

I downloaded screem (web development environment) and tried to compile it, but after running ./configure I get this error.

checking for SCREEM... configure: error: Package requirements (         gtk+-2.0 >= 2.6.0                       glib-2.0 >= 2.6.0                       libgnome-2.0 >= 2.2.0                       libgnomeui-2.0 >= 2.6.0     libxml-2.0 >= 2.4.3                     libglade-2.0 >= 2.3.0                       gconf-2.0 >= 2.2.0gnome-vfs-2.0 >= 2.8.3                        gdk-pixbuf-2.0 >= 2.2.0                     gthread-2.0 >= 2.2.0                        libgtkhtml-2.0 >= 2.2.0                     gmodule-2.0 >= 2.2.0            libgnomeprint-2.2 >= 2.2.0                  libgnomeprintui-2.2 >= 2.2.0                    gtksourceview-1.0 >= 1.1.90                     libstartup-notification-1.0                                     libgnome-menu >= 2.9.2      ) were not met:

No package 'libgtkhtml-2.0' found
No package 'libgnomeprint-2.2' found
No package 'libgnomeprintui-2.2' found
No package 'gtksourceview-1.0' found
No package 'libgnome-menu' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SCREEM_CFLAGS
and SCREEM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I tried to find the missing packages using apt-cache search but no luck with the exception of libgnome-menu

How do I install screem in Ubuntu 12.10(amd64)

Best Answer

  • Screem was in the repositories for Hardy (8.04 LTS), as this Launchpad page shows, but that was around five years ago. The Ubuntu packages page contains details about it, but the problem in either installing or compiling lies in that it requires very old dependencies that are not compatible with the current 12.10 packages.

    The package you mention, 'libgtkhtml-2.0' was in the repositories for Hardy with the accompanying -dev files necessary for compilation, as were most of the other necessary dependencies, but they can't be installed to the system on 12.10 without causing a lot of problems.

    Unfortunately, there hasn't been much active development of the project for a long while, going by the mailing-lists and the code commits, although someone did try compiling recently (2011) and the answer noted on the mailing-lists might give you some help, as it points to a more recent version of the project. However, I think the same problem with dependencies will be present.

  • Related Question