Ubuntu – How to install shared libraries

20.04shared library

I have a problem with Cisco PacketTracer

https://www.netacad.com/courses/packet-tracer

wolf@linux:/opt/pt/bin$ ./PacketTracer7
./PacketTracer7: error while loading shared libraries: libQt5WebEngineWidgets.so.5: cannot open shared object file: No such file or directory
wolf@linux:/opt/pt/bin$

It turns out that some of the libraries are not there:

wolf@linux:/opt/pt/bin$ ldd PacketTracer7 | grep not
    libQt5WebEngineWidgets.so.5 => not found
    libQt5WebEngineCore.so.5 => not found
    libQt5Script.so.5 => not found
    libQt5ScriptTools.so.5 => not found
wolf@linux:/opt/pt/bin$

I've tried to install it, but it didn't work:

wolf@linux:/opt/pt/bin$ sudo apt install libQt5WebEngineWidgets.so.5 libQt5WebEngineCore.so.5 libQt5Script.so.5 libQt5ScriptTools.so.5
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libQt5WebEngineWidgets.so.5
E: Unable to locate package libQt5WebEngineCore.so.5
E: Unable to locate package libQt5Script.so.5
E: Unable to locate package libQt5ScriptTools.so.5
wolf@linux:/opt/pt/bin$

I've also tried to change it to lower case and remove .so.5 from the name, but it still didn't work.

sudo apt install libQt5WebEngineWidgets.so libQt5WebEngineCore.so libQt5Script.so libQt5ScriptTools.so

sudo apt install libQt5WebEngineWidgets libQt5WebEngineCore libQt5Script libQt5ScriptTools

sudo apt install libqt5webenginewidgets libqt5webenginecore libqt5script libqt5scripttools

What is the right way to do this?

Update

This will install the first two libraries which are libQt5WebEngineWidgets.so.5 & libQt5WebEngineCore.so.5, but not the last two:

sudo apt install libqt5webenginewidgets5 libqt5webenginecore5

Two more libraries to be installed:

wolf@linux:/opt/pt/bin$ ldd ./PacketTracer7 | g not
    libQt5Script.so.5 => not found
    libQt5ScriptTools.so.5 => not found
wolf@linux:/opt/pt/bin$

Best Answer

  • The library's name must be correct; it's case sensitive too. Try this:

    sudo apt install libqt5webenginewidgets5 libqt5webenginecore5 libqt5script5 libqt5scripttools5
    

    Also, use the shell script provided. Do not run the ELF file directly. That won't work.

    /opt/pt/packettracer
    
  • Related Question