Ubuntu – How to upgrade Ubuntu 16 LTS to 18 LTS after purge-ppa crash

upgrade

During automatic Ubuntu's graphic interface upgrade, it solicitated to do purge-ppa, to purge PPA's… And I do it… But during ppa-purges an error arrives, and now, even on terminal running the command sudo apt upgrade, it say:

The following packages have mismatched dependencies:
  libelementary2: It depends: libefreet-bin
                   It depends: libethumb-client-bin
  terminology: It depends: libefreet-bin
                It depends: libethumb-client-bin
E: Mismatched dependencies. Try using -f.

As suggested I try also apt-get -f install but

sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  dctrl-tools libcgal11v5 libcoin80v5 libiso9660-8 libmcrypt4 libmpcdec6 libopenscenegraph100v5 libopenthreads20 libpcre2-8-0 libpgm-5.2-0
  libvcdinfo0 libxine2 libxine2-bin libxine2-doc libxine2-ffmpeg libxine2-misc-plugins libxine2-plugins snapd-login-service xml2
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libefreet-bin libethumb-client-bin
The following NEW packages will be installed:
  libefreet-bin libethumb-client-bin
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
26 not fully installed or removed.
Need to get 0 B/31.3 kB of archives.
After this operation, 137 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 289060 files and directories currently installed.)
Preparing to unpack .../libefreet-bin_1.8.6-2.5_amd64.deb ...
Unpacking libefreet-bin (1.8.6-2.5) ...
dpkg: error processing archive /var/cache/apt/archives/libefreet-bin_1.8.6-2.5_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/efreetd', which is also in package libefl-bin 201702271931-50218~ubuntu16.04.1
Preparing to unpack .../libethumb-client-bin_1.8.6-2.5_amd64.deb ...
Unpacking libethumb-client-bin (1.8.6-2.5) ...
dpkg: error processing archive /var/cache/apt/archives/libethumb-client-bin_1.8.6-2.5_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/ethumbd', which is also in package libefl-bin 201702271931-50218~ubuntu16.04.1
Errors were encountered while processing:
 /var/cache/apt/archives/libefreet-bin_1.8.6-2.5_amd64.deb
 /var/cache/apt/archives/libethumb-client-bin_1.8.6-2.5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Purges that I do, some of the last ones proceded the error:

sudo ppa-purge ppa:mkusb/unstable
sudo ppa-purge ppa:webupd8team/atom
sudo ppa-purge ppa:ondrej/php

sudo ppa-purge ppa:git-core/ppa
sudo ppa-purge ppa:enlightenment-git/ppa
sudo ppa-purge ppa:smathot/cogscinl
sudo ppa-purge ppa:mkusb/ppa
sudo ppa-purge ppa:gezakovacs/ppa
sudo ppa-purge ppa:mc3man/avidemux1

Best Answer

  • In your particular case I'll recommend to force package installation with

    sudo dpkg -i --force-all /var/cache/apt/archives/libefreet-bin_1.8.6-2.5_amd64.deb
    sudo dpkg -i --force-all /var/cache/apt/archives/libethumb-client-bin_1.8.6-2.5_amd64.deb
    

    and then resume with:

    sudo apt-get -f install
    

    and finally install newest dependencies with

    sudo apt-get dist-upgrade
    
  • Related Question