Ubuntu – How to use Vaapi on intel hd 500 integrated graphics

driversintel graphics

I have a media server that I use that is running Ubuntu 16 LTS. This is a headless system so access is via ssh. The media server that I am running is set up to use vaapi but it gives the following error when I enable it:

[AVHWDeviceContext @ 0x1ade560] No VA display found for device: /dev/dri/renderD128.
[AVHWDeviceContext @ 0x1ade560] No VA display found for device: /dev/dri/renderD128.

I suspect my system might not be using the right driver because when I run lspci I see: 00:02.0 VGA compatible controller: Intel Corporation Device 5a85 (rev 0b)

I would expect if it was the right driver more specific information would be in there.

My motherboard / cpu and integrated video are as follow:
ASRock J3455B-ITX Intel Quad-Core Processor J3455 (up to 2.3 GHz) Mini ITX Motherboard/CPU Combo Integrated Intel HD Graphics 500 video card

The output of vainfo is as follows:

error: XDG_RUNTIME_DIR not set in the environment.
error: can't connect to X server!
libva info: VA-API version 0.39.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.39 (libva 1.7.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Broxton - 1.7.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264MultiviewHigh      : VAEntrypointVLD
      VAProfileH264MultiviewHigh      : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileH264StereoHigh         : VAEntrypointEncSlice
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointEncPicture
      VAProfileVP8Version0_3          : VAEntrypointVLD
      VAProfileVP8Version0_3          : VAEntrypointEncSlice
      VAProfileHEVCMain               : VAEntrypointVLD
      VAProfileHEVCMain               : VAEntrypointEncSlice
      VAProfileHEVCMain10             : VAEntrypointVLD
      VAProfileVP9Profile0            : VAEntrypointVLD

Best Answer

  • I think you should install two packages by
    sudo apt-get install i965-va-driver libvdpau-va-gl1.