Ubuntu – I can’t update BlueZ on Ubuntu 14.04

14.04bluetoothbluez

I can't update BlueZ to its latest version (5.40) on Ubuntu 14.04.

I run the commands provided in the readme file, but I get an error:

./configure --prefix=/usr --mandir=/usr/share/man --sysconfdir=/etc --localstatedir=/var
[…]
checking systemd system unit dir... configure: error: systemd system unit directory is required

According to this question, I should use the following command:

./configure --prefix=/usr --mandir=/usr/share/man --sysconfdir=/etc --localstatedir=/var --enable-experimental --with-systemdsystemunitdir=/lib/systemd/system --with-systemduserunitdir=/usr/lib/systemd

And everything works.

Then I type the command:

make && make install

And everything works.

I check my BlueZ version:

bluetoothd -v
4.101

It didn't work.