Ubuntu – I need downgrade from Subversion 1.8 to subversion 1.7

14.04downgradesvn

I've upgraded system from 13.10 to 14.04 LTS
Now I need downgrade from Subversion 1.8 to Subversion 1.7,
because formats 1.7 vs 1.8 are different and I can not access to svn repo of my team.

I've failed to compile svn from sources: a lot of dependencies, strange errors.

I can not understand why svn has not been packed into standalone deb package.
I'm sure there are a lot of people that need precisely one svn version
and do not need forced svn upgrade.

So, my question is: how can I switch to svn 1.7 from 1.8, staying at Ubuntu 14.04?

Update I've installed svn 1.7.9 on ubuntu 14.04 from source.
Then I've installed svn 1.7.9 on ubuntu 14.04 as described below via apt-get and source.list manipulations

Both cases resulted with message:

The following repository access (RA) modules are available:

  • ra_svn : Module for accessing a repository using the svn network protocol.
    • handles 'svn' scheme
  • ra_local : Module for accessing a repository on local disk.
    • handles 'file' scheme

This message means that I can not access svn repository of my team, because http/https support is not installed.

Update2 I hate Subversion and Ubuntu.
The second day I spend trying to compile Subversion 1.7 on Ubuntu 14.04 with http/https support. No result.
I do not understand, why formats 1.7 and 1.8 of Subversion uncompatible.
I hate Subversion developers.

I do not understand, why the http/https support is absent in
https://launchpad.net/ubuntu/trusty/amd64/subversion/1.7.14-1ubuntu2
https://launchpad.net/ubuntu/trusty/amd64/libsvn1/1.7.14-1ubuntu2

Is it too difficult to give me ONLY ONE deb package, that I can install and forget about configuration?

I thought it'd take me for maximum 10 minutes: sudo apt-get install svn-1.7

But I spend my time configuring neon and serf and trying to fit for conditions of that I don't what.

Best Answer

In order to expand Sylvain Pineaus answer a bit: I had the same problem as OP and I solved it like this:

I added the following lines at the end of /etc/apt/sources.list:

# REMEMBER TO DELETE THIS AFTER SVN 1.7 is installed
deb http://extras.ubuntu.com/ubuntu saucy main
deb http://de.archive.ubuntu.com/ubuntu/ saucy main universe restricted multiverse

Now remove the svn packages with version 1.8

sudo apt-get remove subversion libsvn1

update the sources

sudo apt-get update

and install the correct versions

sudo apt-get install subversion=1.7.9-1+nmu6ubuntu3 libsvn1=1.7.9-1+nmu6ubuntu3

Now we need to fix the version of the packages by

echo subversion hold | sudo dpkg --set-selections
echo libsvn1 hold | sudo dpkg --set-selections
echo libserf1 hold | sudo dpkg --set-selections

The libserf1 is needed by subversion or libsvn1 and is now (in 14.04) called libserf-1-1, I guess.

Now remove the lines of /etc/apt/sources.list that were added and update the sources once again (just to be sure)

sudo apt-get update