Ubuntu – I want to install Autodesk eagle but get getting following error

software installation

./eagle: symbol lookup error: /lib/x86_64-linux-gnu/libGLX_mesa.so.0: undefined symbol: xcb_dri3_get_supported_modifiers

Autodesk eagle requires following dependencies
libc.so.6 with subversion GLIBC_2.14 or higher.

Please Help!!

Best Answer

  • There is some graphics incompatibility of EAGLE and Ubuntu 20.04 LTS.

    As a workaround run it always with:

    env LIBGL_ALWAYS_SOFTWARE=1 ./eagle
    
  • Related Question