Ubuntu – Installing dpkg error “requested operation requires superuser privilege”

dpkginstallationusb-modem

Running Ubuntu Version 13.04 and login as administrator and says I need to a superuser to run dpkg, I thought admin was a superuser. What am I doing wrong?

avid@david-Dell-DM051:~/Documents$ dpkg -i vzaccess-7.5_2766f-1ubuntu1110.deb
dpkg: error: requested operation requires superuser privilege
david@david-Dell-DM051:~/Documents$

Best Answer

  • You still need to use sudo to elevate the dpkg installation, do:

    sudo dpkg -i vzaccess-7.5_2766f-1ubuntu1110.deb
    

    then enter your user password.