Ubuntu – Installing Epson WF-3520

cups-lpddriversepsonprinting

The GUI printer install does not have the driver available. I downloaded the LINUX drivers for the printer from the Epson Website, and used the PPD to install. Returns a CUPS error. Installed the printer via localhost:631. It installed, but said it was missing a filter. Any ideas on how to get all the files where they need to be? Thanks!

Best Answer

  • I had the same problem with my Epson WF-3520 and the driver from the Epson-Website. This solved my problem:

    Try, to make sure the damaged driver will be removed:

    sudo apt-get -f install
    

    And then install the driver from the package manager

    sudo apt-get install printer-driver-escpr
    

    I installed the package "printer-driver-escpr" version 1.3.0-1 with the package manager and the driver works for me with the Epson WF-3520.

    Now, try to add a new printer.

    Application -> System Tools -> System Settings -> Printers
    

    Network priner with connection type:

    LPD/LPR queue 'PASSTHRU'