Ubuntu – Installing Ubuntu with Fake RAID 1

64-bitinstallationraid

I had:

  • Software:

    Dual boot with

    • Windows XP
    • Ubuntu 10.04 LTS x32
  • Hardware
    • Fake RAID 1 (mirroring) with 2×1 TB:

Partition 1 – Windows
Partition 2 – SWAP
Partition 3 – / (root)
Partition 4 – Extended
Partition 5 – /home
Partition 6 – /data

arek@domek:/var/log/installer$ sudo fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000de1b9

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   524297339   262148638+   7  HPFS/NTFS/exFAT
/dev/sda2       524297340   528506369     2104515   82  Linux swap / Solaris
/dev/sda3       528506370   570468149    20980890   83  Linux
/dev/sda4       570468150  1953118439   691325145    5  Extended
/dev/sda5       570468213   675340469    52436128+  83  Linux
/dev/sda6       675340533  1953118439   638888953+  83  Linux

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000de1b9

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63   524297339   262148638+   7  HPFS/NTFS/exFAT
/dev/sdb2       524297340   528506369     2104515   82  Linux swap / Solaris
/dev/sdb3       528506370   570468149    20980890   83  Linux
/dev/sdb4       570468150  1953118439   691325145    5  Extended
/dev/sdb5       570468213   675340469    52436128+  83  Linux
/dev/sdb6       675340533  1953118439   638888953+  83  Linux

arek@domek:/var/log/installer$ ls -l /dev/mapper/
total 0
crw------- 1 root root 10, 236 Oct  7 20:17 control
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha -> ../dm-0
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha1 -> ../dm-1
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha2 -> ../dm-2
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha3 -> ../dm-3
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha4 -> ../dm-4
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha5 -> ../dm-5
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha6 -> ../dm-6

I want to upgrade from 10.04 x32 to 12.04 x64 using FRESH installation.

Best Answer

  • So, run installation of Ubuntu 12.04.1 x64 LTS using alternate CD.

    During the installation I selected manual partitioning and to:
    - Use and Format / (root)
    - Use and Format SWAP
    - Use and Keep data on /home
    - Use and Keep data on /data


    After I clicked "Continue" I get error creating and formatting SWAP partition.

    I go to terminal with Alt + F2 (?) and hit enter.
    I discovered that there was visible RAID as only disk with NO partitions.
    Something like this:

    arek@domek:/var/log/installer$ ls -l /dev/mapper/
    lrwxrwxrwx 1 root root 7 Oct  7 20:17 /dev/mapper/pdc_jhjbcaha -> ../dm-0
    


    arek@domek:/var/log/installer$ ls -l /dev/dm*
    brw-rw---- 1 root disk 252, 0 Oct  7 20:17 /dev/dm-0
    



    So I switched to log console Alt+F3 (?) and saw errors like below:

    Oct  7 14:02:45 check-missing-firmware: /dev/.udev/firmware-missing does not exist, skipping
    Oct  7 14:02:45 check-missing-firmware: /run/udev/firmware-missing does not exist, skipping
    Oct  7 14:02:45 check-missing-firmware: no missing firmware in /dev/.udev/firmware-missing /run/udev/firmware-missing
    Oct  7 14:02:45 anna-install: Installing dmraid-udeb
    Oct  7 14:02:45 anna[12599]: DEBUG: retrieving dmraid-udeb 1.0.0.rc16-4.1ubuntu8
    Oct  7 14:02:49 anna[12599]: DEBUG: retrieving libdmraid1.0.0.rc16-udeb 1.0.0.rc16-4.1ubuntu8
    Oct  7 14:02:49 anna[12599]: DEBUG: retrieving kpartx-udeb 0.4.9-3ubuntu5
    Oct  7 14:02:49 disk-detect: Serial ATA RAID disk(s) detected.
    Oct  7 14:02:55 disk-detect: Enabling dmraid support.
    Oct  7 14:02:55 disk-detect: RAID set "pdc_jhjbcaha" was activated
    Oct  7 14:02:55 HERE --> dmraid-activate: ERROR: Cannot retrieve RAID set information for pdc_jhjbcaha 
    Oct  7 14:02:56 check-missing-firmware: /dev/.udev/firmware-missing does not exist, skipping
    Oct  7 14:02:56 check-missing-firmware: /run/udev/firmware-missing does not exist, skipping
    Oct  7 14:02:56 check-missing-firmware: no missing firmware in /dev/.udev/firmware-missing /run/udev/firmware-missing
    Oct  7 14:02:57 main-menu[428]: DEBUG: resolver (libnewt0.52): package doesn't exist (ignored)
    Oct  7 14:02:57 main-menu[428]: DEBUG: resolver (ext2-modules): package doesn't exist (ignored)
    Oct  7 14:02:57 main-menu[428]: INFO: Menu item 'partman-base' selected
    Oct  7 14:02:57 kernel: [  316.512999] NTFS driver 2.1.30 [Flags: R/O MODULE].
    Oct  7 14:02:57 kernel: [  316.523221] Btrfs loaded
    Oct  7 14:02:57 kernel: [  316.534781] JFS: nTxBlock = 8192, nTxLock = 65536
    Oct  7 14:02:57 kernel: [  316.554749] SGI XFS with ACLs, security attributes, realtime, large block/inode numbers, no debug enabled
    Oct  7 14:02:57 kernel: [  316.555336] SGI XFS Quota Management subsystem
    Oct  7 14:02:58 md-devices: mdadm: No arrays found in config file or automatically
    Oct  7 14:02:58 partman:   No matching physical volumes found
    Oct  7 14:02:58 partman:   No volume groups found
    Oct  7 14:02:58 partman:   Reading all physical volumes.  This may take a while...
    Oct  7 14:02:58 partman-lvm:   No volume groups found
    Oct  7 14:02:58 partman: Error running 'tune2fs -l /dev/mapper/pdc_jhjbcaha'
    Oct  7 14:02:58 partman: Error running 'tune2fs -l /dev/mapper/pdc_jhjbcaha'
    Oct  7 14:02:58 partman: Error running 'tune2fs -l /dev/mapper/pdc_jhjbcaha'
    Oct  7 14:06:11 HERE --> partman: mkswap: can't open '/dev/mapper/pdc_jhjbcaha2': No such file or directory
    Oct  7 14:07:28 init: starting pid 401, tty '/dev/tty2': '-/bin/sh'
    Oct  7 14:15:00 net/hw-detect.hotplug: Detected hotpluggable network interface eth0
    Oct  7 14:15:00 net/hw-detect.hotplug: Detected hotpluggable network interface lo
    


    As You can see there are 2 errors

    Oct  7 14:02:55 dmraid-activate: ERROR: Cannot retrieve RAID set information for pdc_jhjbcaha
    


    and

    Oct  7 14:06:11 partman: mkswap: can't open '/dev/mapper/pdc_jhjbcaha2': No such file or directory
    


    I looked in the internet and try to run command "dmraid -ay" and get something like that:


    dmraid -ay
    /dev/mapper/pdc_jhjbcaha -> Already activated
    /dev/mapper/pdc_jhjbcaha1 -> Successfully activated
    /dev/mapper/pdc_jhjbcaha2 -> Successfully activated
    /dev/mapper/pdc_jhjbcaha3 -> Successfully activated
    /dev/mapper/pdc_jhjbcaha4 -> Successfully activated
    /dev/mapper/pdc_jhjbcaha5 -> Successfully activated
    /dev/mapper/pdc_jhjbcaha6 -> Successfully activated
    



    Then I returned to installer with Alt+F1 (?) and click "Return" to return to partitioning menu. I did NOT change anything just selected again "Continue" and everything goes smoothly.

    I hope this will help someone.

    arkadius