Ubuntu – Kernel configuration is invalid error while trying to install paragon ufsd professional drivers for HFS+

compilingdkmsdriverskernel

short question:

While running the install.sh Skript for Paragon UFSD drivers I get the Error message:

 ERROR: Kernel configuration is invalid."; 
\include/generated/autoconf.h or include/config/auto.conf are missing."$
 Run 'make oldconfig && make prepare' on kernel src to fix it.";      \

How can I run "make oldconfig && make prepare" and does that make sense?

Disclaimer:

I know this question was asked in context of NVIDIA driver, but it was answered by suggesting other ways to install NVIDIA not telling how to run the make command (Installing NVIDIA Driver: Error Run 'make oldconfig && make prepare' on kernel src to fix it."). In another question the problem was solved but the person who asked can not remember how ("ERROR: Kernel configuration is invalid").

Context for my question:

I am trying now for several days to install the Paragon-147-PRE_NTFS_Linux_9.4_Pro UFSD drivers for full read&write NTFS and HFS+ filesystem support. The drivers officially support Ubuntu 16.04LTS.
After crunching my old Linux installation I use a fresh install of Ubuntu 16.04.2LTS (downloaded from the UBUNTU website) with nothing but the standard installation, though I run it on a triple boot system (Windows7, elementary, Ubuntu) if that matters.

I installed the build-essentials, dkms and linux-headers:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install build-essential
sudo install dkms
sudo apt-get install linux-generic
sudo apt-get install linux-signed-generic
uname -a
Linux notebook 4.8.0-39-generic #42~16.04.1-Ubuntu SMP Mon Feb 20 15:06:07 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

As far as I know I match all requirements (hardware and installed software) listed in the paragon manual (http://download.paragon-software.com/doc/ntfs_hfs_linux_9_4_user_manual.pdf):

»build-essential« ist bereits die neuste Version (12.1ubuntu2).
gcc (Ubuntu 5.4.0-6ubuntu1~16.04.4) 5.4.0 20160609
g++ (Ubuntu 5.4.0-6ubuntu1~16.04.4) 5.4.0 20160609
GNU Make 4.1
Gebaut für x86_64-pc-linux-gnu
GNU ld (GNU Binutils for Ubuntu) 2.26.1
kmod version 22
-XZ -ZLIB -EXPERIMENTAL
dkms: 2.2.0.3

I unpacked the Paragon driver package and started the install.sh skript (note on the "out of range" warning: I previously tried it on 4.4. kernel without that warning but the same final error message):

viejo@notebook:/usr/tmp/ufsd/Paragon-147-PRE_NTFS_Linux_9.4_Pro$ sudo ./install.sh
By installing this software you accept the terms of End User License Agreement listed in License file.
Continue installing? [yes/no/read].
yes
Current kernel version is out of supported range. Proceed at your own risk? [yes/No]
yes
Searching and removing previously installed UFSD driver in /lib/modules/4.8.0-39-generic/
Would you like to mount NTFS/HFS+ volumes with UFSD driver automatically? [yes/no]
yes
Automount configured
Would you like UFSD driver to rebuild after kernel updates? [yes/no]
yes
Setting DKMS configuration
Preparing to install
ERROR (dkms apport): binary package for paragon-ufsd: head not found
Error! Bad return status for module build on kernel: 4.8.0-39-generic (x86_64)
Consult /var/lib/dkms/paragon-ufsd/head/build/make.log for more information.
Can't prepare driver configuration
cat: /var/lib/dkms/paragon-ufsd/head/4.8.0-39-generic/x86_64/log/make.log: Datei oder Verzeichnis nicht gefunden

In the make.log I found this error message:

...
make[2]: Verzeichnis „/usr/src/linux-headers-4.8.0-39-generic“ wird betreten
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (                \
echo >&2;                                                       \
echo >&2 "  ERROR: Kernel configuration is invalid.";           \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing."$
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";      \
echo >&2 ;                                                      \
/bin/false)
...
cc1: all warnings being treated as errors
/usr/src/linux-headers-4.8.0-39-generic/scripts/Makefile.build:289: die Regel für Ziel „/$
make[3]: *** [/var/lib/dkms/paragon-ufsd/head/build/ifslinux/ufsdjnl.o] Fehler 1
/usr/src/linux-headers-4.8.0-39-generic/Makefile:1491: die Regel für Ziel „_module_/var/l$
make[2]: *** [_module_/var/lib/dkms/paragon-ufsd/head/build] Fehler 2
make[2]: Verzeichnis „/usr/src/linux-headers-4.8.0-39-generic“ wird verlassen
Makefile:150: die Regel für Ziel „sub-make“ scheiterte
make[1]: *** [sub-make] Fehler 2
make[1]: Verzeichnis „/usr/src/linux-headers-4.8.0-39-generic“ wird verlassen
Makefile:94: die Regel für Ziel „ufsd.ko“ scheiterte
make: *** [ufsd.ko] Fehler 2

when looking for the source-code files and the config-file as suggested in the Paragon Manual troubleshooting it seems to me, that I have everything needed:

viejo@notebook:/usr/src/linux-headers-4.8.0-39-generic$ ls
arch    Documentation  include  Kconfig   mm              scripts   tools   zfs
block   drivers        init     kernel    Module.symvers  security  ubuntu
certs   firmware       ipc      lib       net             sound     usr
crypto  fs             Kbuild   Makefile  samples         spl       virt

viejo@notebook:/boot$ ls
abi-4.4.0-64-generic         memtest86+.bin
abi-4.8.0-36-generic         memtest86+.elf
abi-4.8.0-39-generic         memtest86+_multiboot.bin
config-4.4.0-64-generic      System.map-4.4.0-64-generic
config-4.8.0-36-generic      System.map-4.8.0-36-generic
config-4.8.0-39-generic      System.map-4.8.0-39-generic
efi                          vmlinuz-4.4.0-64-generic
grub                         vmlinuz-4.4.0-64-generic.efi.signed
initrd.img-4.4.0-64-generic  vmlinuz-4.8.0-36-generic
initrd.img-4.8.0-36-generic  vmlinuz-4.8.0-39-generic
initrd.img-4.8.0-39-generic  vmlinuz-4.8.0-39-generic.efi.signed

I do not know how to proceed. I would be greatful for any help or hint where I can get more information.

Olaf

Best Answer

  • I just want to share how I solved my problem regarding the installation of Paragon Professional UFSD drivers for HFS+ and NTFS in case anybody else run into similar problems.

    I created a support Ticket at Paragon and got a new build that supports Ubuntu 16.4.2lts with 4.8 kernel.

    No need to run make oldconfig etc...

    But be aware, you still need to install the build-essentials, dkms and source code (headers):

    sudo apt-get install build-essential
    sudo apt-get install dkms
    sudo apt-get install linux-generic
    sudo apt-get install linux-signed-generic
    

    good luck Olaf