Repositories: universe, main
Ran apt-get update
Ran apt-cache policy libssl1.0.0
ddew@ddew-wsl:~$ apt-cache policy libssl1.0.0 libssl1.0.0: Installed: 1.0.1f-1ubuntu2.11 Candidate: 1.0.1f-1ubuntu2.11 Version table: *** 1.0.1f-1ubuntu2.11 0 100 /var/lib/dpkg/status 1.0.1f-1ubuntu2 0 500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
Was surprised to see that the version advertised as the candidate is not the same as what is available from main and that the version available from main is older than the version that is already installed.
Attempted to install libssl-dev
ddew@ddew-wsl:~$ sudo apt-get install libssl-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libssl-dev : Depends: libssl1.0.0 (= 1.0.1f-1ubuntu2) but 1.0.1f-1ubuntu2.11 is to be installed Recommends: libssl-doc but it is not going to be installed E: Unable to correct problems, you have held broken packages.
Out of curiosity, ran apt-cache policy libssl-dev
ddew@ddew-wsl:~$ apt-cache policy libssl-dev libssl-dev: Installed: (none) Candidate: 1.0.1f-1ubuntu2 Version table: 1.0.1f-1ubuntu2 0 500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages