Ubuntu – MySQL not working after upgrade from 14.04 to 16.04

14.0416.04MySQL

After a good deal of troubleshooting I have managed to get Plasma running however MySQL will still not start

systemctl status mysql.service
â mysql.service - MySQL Community Server
   Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled)
   Active: inactive (dead) (Result: exit-code) since Thu 2016-05-26 15:43:35 CDT; 36s ago
  Process: 18735 ExecStartPost=/usr/share/mysql/mysql-systemd-start post (code=exited, status=0/SUCCESS)
  Process: 18734 ExecStart=/usr/sbin/mysqld (code=exited, status=1/FAILURE)
  Process: 18946 ExecStartPre=/usr/share/mysql/mysql-systemd-start pre (code=exited, status=1/FAILURE)
 Main PID: 18734 (code=exited, status=1/FAILURE)

May 26 15:43:34 Stark.newbierpg.com systemd[1]: Failed to start MySQL Community Server.
May 26 15:43:34 Stark.newbierpg.com systemd[1]: mysql.service: Unit entered failed state.
May 26 15:43:34 Stark.newbierpg.com systemd[1]: mysql.service: Failed with result 'exit-code'.
May 26 15:43:35 Stark.newbierpg.com systemd[1]: mysql.service: Service hold-off time over, scheduling restart.
May 26 15:43:35 Stark.newbierpg.com systemd[1]: Stopped MySQL Community Server.
May 26 15:43:35 Stark.newbierpg.com systemd[1]: mysql.service: Start request repeated too quickly.
May 26 15:43:35 Stark.newbierpg.com systemd[1]: Failed to start MySQL Community Server.
root@Stark:/etc# service mysql start
Job for mysql.service failed because the control process exited with error code. See "systemctl status mysql.service" and "journalctl -xe" for details.
root@Stark:/etc# systemctl status mysql.service
â mysql.service - MySQL Community Server
   Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled)
   Active: activating (start-post) (Result: exit-code) since Thu 2016-05-26 15:47:30 CDT; 3s ago
  Process: 20207 ExecStart=/usr/sbin/mysqld (code=exited, status=1/FAILURE)
  Process: 20205 ExecStartPre=/usr/share/mysql/mysql-systemd-start pre (code=exited, status=0/SUCCESS)
 Main PID: 20207 (code=exited, status=1/FAILURE);         : 20208 (mysql-systemd-s)
   CGroup: /system.slice/mysql.service
           ââcontrol
             ââ20208 /bin/bash /usr/share/mysql/mysql-systemd-start post
             ââ20245 sleep 1

May 26 15:47:30 Stark.newbierpg.com systemd[1]: Starting MySQL Community Server...
May 26 15:47:33 Stark.newbierpg.com systemd[1]: mysql.service: Main process exited, code=exited, status=1/FAILURE

Best Answer

  • we were also facing same issue after Upgarde from 14.04 to 16.04 Solved the problem by removing

    myisam-recover = BACKUP
    

    and

    key_buffer = 16M
    

    from my.cnf.

    Then use

    sudo service mysql start
    

    to start the MySQL daemon again and

    sudo apt-get -f install 
    

    to recover your system packaging state.

    I found this advicehere: https://bugs.launchpad.net/ubuntu/+source/mysql-5.7/+bug/1570673, you can check also

  • Related Question