Ubuntu – No Sound on XPS 17 9700

20.04dellxps

I have just got a new XPS 17 9700…
I am new to Linux and I am having problems getting sound to work.
Everything else works fine except the sound which works fine when booting in Windows.
I am running Ubuntu 20.04.

Can anyone help?

Thanks a lot.

Best Answer

  • I found this on Reddit and it worked perfectly for me...

    How to get fully working audio on XPS 9700 in Ubuntu 20.04:

    1. Download and install dkms module:

      https://launchpad.net/~canonical-hwe-team/+archive/ubuntu/pc-oem-dkms/+packages

      Alternatively, you can install linux-oem-20.04, it will install the 5.6 kernel with the above driver. Your system may be more stable with 5.4 kernel since it is in wide use.

    2. Manually install sof-firmware from Arch Linux:

      https://archlinux.pkgs.org/rolling/archlinux-extra-x86_64/sof-firmware-1.5.1-1-any.pkg.tar.zst.html

      You will need to delete the existing "sof" and "sof-tplg" files from the Ubuntu linux-firmware package first. Note if this package gets updated from Canoncial and they don't update these, you will have to delete and then reextract. Files go into the /usr/lib/firmware/intel/sof and /usr/lib/firmware/intel/sof-tplg folders.

    3. Manually install the ucm2 files:

      http://xps17.ddns.net/sof-soundwire.zip

      These go into /usr/share/alsa/ucm2/sof-soundwire. Delete the contents of the existing sof-soundwire folder (if you have it) and replace them with the ones from the archive.

    4. Reboot. You should now have all your audio devices available. If speakers do not play, you may need to run alsamixer (non-root) from a terminal and unmute and set the mixer levels all the way up.

  • Related Question