Ubuntu – No version of Ubuntu can be installed with any Skylake 6th generation Intel processor

driversintel graphicskernelsystem-installation

Ubuntu can't be installed on my system because of what the title says. This is because support Intel HD Graphics 530 was only just added in Linux kernel 4.3 and all versions of Ubuntu only have kernel versions up to 4.2 as of 15.10. My computer's processor is the new Intel Skylake 6600K if you need to know, everything else is generic. It has a UEFI BIOS motherboard. Help?

Best Answer

  • Boot with nomodeset boot parameter as it is described in this answer.

    You will be able to install Ubuntu. After you do it, the system will probably won't boot again.

    You will have to get to grub menu by pressing Shift or ESC button and enter nomodeset again.

    Then install 4.3 kernel. It can be done this way. Run in terminal:

    mkdir ~/linux-4.3
    cd ~/linux-4.3
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300_4.3.0-040300.201511020949_all.deb
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-image-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb
    sudo dpkg -i *.deb
    

    and reboot. I hope the system will boot without the nomodeset parameter.

    Notice: The kernel will not get updates. You will need to install them manually from Mainline kernel PPA.

  • Related Question