Ubuntu – OpenGL GLX context is not using direct rendering, which may cause performance problems. (steam) AMD DRIVER

14.0414.10atidriverssteam

When I start steam in a terminal, I get the following error messages

charlie@SteamMPL:~$ steam
rm: no se puede borrar «/home/charlie/.steam/steam»: Es un directorio
rm: no se puede borrar «/home/charlie/.steam/bin»: Es un directorio
Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME is enabled automatically
[2014-08-03 11:50:13] Startup - updater built Jul 15 2014 18:14:26
Installing breakpad exception handler for appid(steam)/version(1405474565_client)
libGL error: failed to load driver: swrast
Looks like steam didn't shutdown cleanly, scheduling immediate update check
Installing breakpad exception handler for appid(steam)/version(1405474565_client)
[2014-08-03 11:50:14] Checking for update on startup
[2014-08-03 11:50:14] Buscando actualizaciones disponibles...
Installing breakpad exception handler for appid(steam)/version(1405474565_client)
[2014-08-03 11:50:14] Download skipped: /client/steam_client_ubuntu12 version 1405474565, installed version 1405474565
[2014-08-03 11:50:14] Nothing to do
[2014-08-03 11:50:14] Verificando instalación...
[2014-08-03 11:50:14] Performing checksum verification of executable files
[2014-08-03 11:50:15] Verification complete
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "unity-gtk-module"
Installing breakpad exception handler for appid(steam)/version(1405474565_client)
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number
[0803/115015:WARNING:proxy_service.cc(958)] PAC support disabled because there is no system implementation
libGL error: failed to load driver: swrast
Error: OpenGL GLX context is not using direct rendering, which may cause performance problems.

Hardware information:

  • CPU: AMD Athlon x4 760k
  • GPU: AMD Radeon R7 250 1 GB GDDR5 (Driver: Catalyst 14.4)
  • RAM: 8 GB DDR3 1600

What can I do to circumvent this issue?

Best Answer

  • Steam ships with it's own gcc libraries, which are outdated and do not work on distributions with newer libraries. For further information, check out: https://wiki.archlinux.org/index.php/steam#Steam_runtime_issues

    To solve your problem on Ubuntu 14.04, close Steam and run:

    rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libgcc_s.so.1
    rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6
    rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1
    rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6
    rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libxcb.so.1
    

    On 14.10, the path changed, commands are similar:

    rm ~/.steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libgcc_s.so.1
    rm ~/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6
    rm ~/.steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1
    rm ~/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6
    rm ~/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libxcb.so.1
    

    or

    rm ~/.steam/bin32/steam-runtime/amd64/lib/x86_64-linux-gnu/libgcc_s.so.1
    rm ~/.steam/bin32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6
    rm ~/.steam/bin32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1
    rm ~/.steam/bin32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6
    rm ~/.steam/bin32/steam-runtime/i386/usr/lib/i386-linux-gnu/libxcb.so.1
    
  • Related Question