Ubuntu – PHP 5.6 not used by Apache instead it uses PHP 5.5

Apache2PHPserver

I am trying to upgrade my PHP version from 5.5 to 5.6 so I can get Laravel working. So I followed the instructions from here but instead of adding this repository:

sudo add-apt-repository ppa:ondrej/php5-5.6

I added this:

sudo add-apt-repository ppa:ondrej/php5

anything else didn't work. Afterwards I installed PHP and to test the version I did this:

php -v

which gave me this:

PHP 5.6.28-1+deb.sury.org~trusty+1

however when I navigate to the server in my browser phpinfo() showed this:

PHP Version 5.5.9-1ubuntu4.20

Why is that happening, why isn't Apache loading the new version?

Also, in my /etc folder I have two php folders one is: /etc/php5 (which I think contains php5.5) and another called: /etc/php (which I think contains php5.6).

Best Answer

  • I found out that I have the following files inside /etc/apache2/mods-available/

    php5.6.conf
    php5.6.load
    php5.conf
    php5.load
    php5filter.conf
    php5filter.load
    php7.0.conf
    php7.0.load
    

    so what I did is the following

    sudo a2dismod php5.load
    

    and then

    sudo a2enmod php5.6.load
    

    that switched the version the apache was using to 5.6 and voila problem solved : )