Ubuntu – Problem while installing vlc player

aptdependenciespackage-managementsoftware installationvlc

I can't install vlc player on my Ubuntu(14.04).
I have read this and try to run the commands, but while I run this command:

sudo apt-get install vlc

I got something like this:

    Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1) but 2.1.6-0ubuntu14.04.1 is to be installed
       Recommends: vlc-plugin-notify (= 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1) but 2.1.6-0ubuntu14.04.1 is to be installed
       Recommends: vlc-plugin-pulse (= 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1) but 2.1.6-0ubuntu14.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

What is the problem? Have you any Idea to solve this or Could you please tell me the right procedure by which I can install vlc media player?


Update:

After removing the PPA, this is the output of apt-cache policy vlc:

vlc: 
  Installed:  (none) 
  Candidate:  2.1.2-2build2 
    Version table: 
      2.1.6-0ubuntu14.04.1 0 
        100 /var/lib/dpkg/status 
      2.1.2-2build2 0 
        500 archive.ubuntu.com/ubuntu trusty/universe i386 Packages 
      2.0.1-4 0 
        500 archive.ubuntu.com/ubuntu precise/universe i386 Packages

And The command:

apt-cache policy vlc-nox vlc-plugin-notify vlc-plugin-pulse

gives me the following results:

vlc-nox:
  Installed: 2.1.6-0ubuntu14.04.1
  Candidate: 2.1.6-0ubuntu14.04.1
  Version table:
 *** 2.1.6-0ubuntu14.04.1 0
        100 /var/lib/dpkg/status
     2.1.2-2build2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
     2.0.1-4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
vlc-plugin-notify:
  Installed: 2.1.6-0ubuntu14.04.1
  Candidate: 2.1.6-0ubuntu14.04.1
  Version table:
 *** 2.1.6-0ubuntu14.04.1 0
        100 /var/lib/dpkg/status
     2.1.2-2build2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
     2.0.1-4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
vlc-plugin-pulse:
  Installed: 2.1.6-0ubuntu14.04.1
  Candidate: 2.1.6-0ubuntu14.04.1
  Version table:
 *** 2.1.6-0ubuntu14.04.1 0
        100 /var/lib/dpkg/status
     2.1.2-2build2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
     2.0.1-4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe i386 Packages

Best Answer

  • Don't use the PPA, install vlc from the Ubuntu repositories.

    1. Remove the PPA you have installed:

      sudo add-apt-repository --remove ppa:videolan/stable-daily
      
    2. Empty the package cache:

      sudo apt-get clean
      
    3. Update your package lists:

      sudo apt-get update
      
    4. Downgrade/install all vlc packages to/in the repository version:

      sudo apt-get install --reinstall vlc=2.1.2-2build2 vlc-data=2.1.2-2build2 vlc-nox=2.1.2-2build2 vlc-plugin-notify=2.1.2-2build2 vlc-plugin-pulse=2.1.2-2build2
      

    Depending on your Ubuntu version, you might currently (Nov 20, 2015) get a VLC version up to 2.2.1-3 on Wily (15.10). Older Ubuntu versions might have older VLC versions in their repositories.

    You check the versions available for you with the command:

    apt-cache policy vlc
    

    An example output on my 15.10 64bit system would be:

    vlc:
      Installed: (none)
      Candidate: 2.2.1-3
      Version table:
         2.2.1-3 0
            500 http://[YOUR REPOSITORY SERVER URL]/ wily/universe amd64 Packages