Ubuntu – Resolving dependencies related to 32 bit libraries on 64 bit

64-bitadobe-air

I am struggling to make a 32bit application (related to adobe AIR)
work on my 64bit Ubuntu system. The application starts fine but there
is no sound. After running the application from the terminal, I've
noticed the following error messages:

/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64
Gtk-WARNING **: Failed to load type module:
/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong
ELF class: ELFCLASS64
Gtk-WARNING **: Loading IM context type 'ibus' failed
Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong
ELF class: ELFCLASS64
Gtk-WARNING **: Loading IM context type 'ibus' failed

I suspect the following errors could be resolved by a careful
update/downgrade of some specific libraries in the ia32 package. Since
I am not a Linux expert I was wondering if someone could suggest me
some ways to try to fix the above error messages. Thanks.