Ubuntu – Sound works but no device shown in the Sound settings

12.04acerindicator-soundsoundsoundcard

Following a troubleshooting post I've found out that my driver is recognized in fact but is not listed at the sound settings and I think because of this my cinnamon sound applet will not appear. Altough my device does not appear in the Sound settings I get sounds (for example youtube and skype is working) but I can not increase/decrease the volume…

I tried enabling login with root, login-logout and then login with user, restarts, following other ideas saying to fix this but still no sound devices listed… still it works (browser, skype…), alsamixer works.

Any idea on how to fix this?

lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Subsystem: Acer Incorporated [ALI] Device 0205
Flags: bus master, fast devsel, latency 0, IRQ 46
Memory at f4700000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel
lsmod | grep snd
 snd_hda_codec_hdmi     31731  1 
snd_hda_codec_realtek    63371  1 
snd_hda_intel          32621  0 
snd_hda_codec         115893  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13276  1 snd_hda_codec
snd_pcm                80845  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi           13132  0 
snd_rawmidi            25424  1 snd_seq_midi
snd_seq_midi_event     14475  1 snd_seq_midi
snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
snd_timer              28931  2 snd_pcm,snd_seq
snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    62064  10 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              14635  1 snd
snd_page_alloc         14108  2 snd_hda_intel,snd_pcm

Also… in cinnamon the sound applet is not displayed in unity it displays as if it were muted.

Similar question:
Ubuntu 12.04, Can hear the sound but Sound option in settings shows no sound card

Best Answer

  • Ubuntu Unity 14.04 - 64bit, Intel mobo and i7 processor. After switching sound cards, I had [much better] sound but my sound output choices (System Settings : Sound) disappeared. I needed that to switch to S/PDIF output. After much monkeying around without success, including all of the above suggestions and more, nothing worked. For no particular reason, I logged into a 2nd user account, where I found the new output choices did indeed appear. I'd discovered that the settings were user-account specific. So, while I was there, I looked in .config and found a pulse directory. I copied that directory to the network, then switched back to the primary account. I found my .config/pulse directory (which had several additional files in it) and renamed it to pulse.orig in preparation to copy/paste the 2nd account's pulse directory from the network. But even as I switched directories to copy, then back to my .config directory, a new pulse directory had appeared, with the proper number of files in it. I checked System Settings / Sound, and my new sound devices were available for selection.

    Long Story Short: Maybe find your [/home/userid]/.config/pulse directory and rename it (so a new default copy can appear).