Ubuntu – Steam dependencies can’t be installed

aptdependenciessteam

I found a few questions that were similar to this but none of them were enough like my particular case to be of any use.

Whenever I open Steam, a terminal opens up:

Steam needs to install these additional packages: 
    libgl1-mesa-dri:i386, libgl1-mesa-glx:i386

I enter my password and hit enter:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.5.0~git20150204.661c8bb2-0ubuntu0ricotz~trusty)
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Press return to continue: 

This is a fresh install of Ubuntu 14.04 and Steam. The last time I tried this, I ended up screwing the system up trying to resolve these various dependencies. What steps do I need to take to fix this?

If it matters, this is 64-bit, I'm using my gtx980 graphics card's NVIDIA driver installed from a PPA, and I can provide any hardware info if necessary.

I tried using the
sudo apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386
command and a second time with the -f option, with the latter resulting in:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:   
libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (=        
10.5.0~git20150204.661c8bb2-0ubuntu0ricotz~trusty)
unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                    Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Best Answer

  • Try sudo apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386. If that fails, or it doesn't fix the problem, do sudo apt-get install -f.