Ubuntu – Steam is not working: SteamUpdateUI: An X Error occurred

steam

I have error when try to open steam:

Running Steam on ubuntu 18.04 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
[2019-07-26 00:23:06] Startup - updater built Jul 17 2019 06:13:47
SteamUpdateUI: An X Error occurred
X Error of failed request:  GLXBadContext
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
Major opcode of failed request:  154 (GLX)
Minor opcode of failed request:  3 (X_GLXCreateContext)
Value in failed request:  0x0
Serial number of failed request:  45
xerror_handler: X failed, continuing
Major opcode of failed request:  154 (GLX)
Minor opcode of failed request:  6 (X_GLXIsDirect)
Serial number of failed request:  46
xerror_handler: X failed, continuing
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2019-07-26 00:23:06] Checking for update on startup
[2019-07-26 00:23:06] Checking for available updates...
[2019-07-26 00:23:06] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2019-07-26 00:23:06] Download skipped by HTTP 304 Not Modified
[2019-07-26 00:23:06] Nothing to do
[2019-07-26 00:23:06] Verifying installation...
[2019-07-26 00:23:06] Performing checksum verification of executable files
[2019-07-26 00:23:07] Verification complete

information of system:
uname -a

Linux home-PC 4.18.0-25-generic #26~18.04.1-Ubuntu SMP Thu Jun 27 07:28:31 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Best Answer

  • The instructions on this page worked for me (Ubuntu 18.04, GTX 1650s): https://github.com/lutris/docs/blob/master/InstallingDrivers.md

    Nvidia:

    To get the latest Nvidia drivers it is necessary to add the Proprietary GPU Drivers PPA:

    sudo add-apt-repository ppa:graphics-drivers/ppa

    Enable 32 bit architecture (if you haven't already):

    sudo dpkg --add-architecture i386

    Update to refresh packages:

    sudo apt update

    Warning: Please ensure your graphics card is supported by the 430 driver before installing. For a list of supported GPUs click here: https://www.nvidia.com/Download/driverResults.aspx/149138/en-us

    Install the 440.82 driver:

    sudo apt install nvidia-driver-440 libnvidia-gl-440 libnvidia-gl-440:i386

    Install support for Vulkan API (will be functional only if you have a Vulkan capable GPU):

    sudo apt install libvulkan1 libvulkan1:i386

    Reboot to apply changes.