Ubuntu – Steam not working on Ubuntu 20.04

20.0432-bitgraphicssteam

Steam's client is still 32-bit. Ubuntu 20.04 has now removed 32bit arch support.
Cannot install lib32bz2-1.0. Steam is not running.

Running Steam on ubuntu 20.04 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
/home/black/.steam/ubuntu12_32/steam -nominidumps -nobreakpad
[2020-04-25 01:22:21] Startup - updater built Apr  4 2020 00:37:13
SteamUpdateUI: An X Error occurred
X Error of failed request:  GLXBadContext
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
Major opcode of failed request:  152 (GLX)
Minor opcode of failed request:  3 (X_GLXCreateContext)
Value in failed request:  0x0
Serial number of failed request:  51
xerror_handler: X failed, continuing
Major opcode of failed request:  152 (GLX)
Minor opcode of failed request:  6 (X_GLXIsDirect)
Serial number of failed request:  52
xerror_handler: X failed, continuing
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2020-04-25 01:22:21] Checking for update on startup
[2020-04-25 01:22:21] Checking for available updates...
[2020-04-25 01:22:21] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2020-04-25 01:22:22] Download skipped: /client/steam_client_ubuntu12 version 1586022601, installed version 1586022601
[2020-04-25 01:22:22] Nothing to do
[2020-04-25 01:22:22] Verifying installation...
[2020-04-25 01:22:22] Performing checksum verification of executable files
[2020-04-25 01:22:22] Verification complete

Tried

sudo dpkg --add-architecture i386
sudo apt install lib32z1 lib32ncurses6

And

sudo apt-get install lib32bz2-1.0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package lib32bz2-1.0
E: Couldn't find any package by glob 'lib32bz2-1.0'
E: Couldn't find any package by regex 'lib32bz2-1.0'

Manually found it's the package here: https://ubuntu.pkgs.org/14.04/ubuntu-main-amd64/lib32bz2-dev_1.0.6-5_amd64.deb.html Says unmet dependencies.

I have Nvidia 2060, it is working fine, even with CUDA. When I was on 18.04, I was playing CS:GO. And now steam/CS:GO won't open.

Best Answer

  • This worked for me.

    sudo apt-get install libnvidia-gl-440:i386
    

    This worked because the issue was with the graphics and Ubuntu 20.04 combined. This library has 32bit files for Nvidia's gpu. These 32bit files were removed while upgrading from 18.04 to 20.04.

    Though they asked about it, on which most people just clicked on ok continue. I did the same.

    Edit: as of 26, July 2020, nvidia's driver 450 is available but it's i386 is having issues. So until then stick with 440.

    Edit: It works with nvidia's driver 450 i386 as well now.