Ubuntu – Touchscreen stops working a few seconds after login to Gnome/Ubuntu session (Ubuntu 20.04)

driversgnometouchscreenxorg

I cannot manage to make my touchscreen to work properly on a fresh installation of Ubuntu 20.04. On the login screen I can still touch the screen to select the user and the password edit box. Even in the first few seconds after login to Gnome/Ubuntu desktop the touchscreen stays responsive for a few seconds but then stops working (just enough time to start a terminal..)

Informations

  • Laptop/Convertible: HP Spectre x360 13-4230ng
  • Touchscreen: SYNAPTICS Synaptics Touch Digitizer V04 (according to xinput and evtest)
  • Driver used in the xorg-server: libinput (I tried evdev, but then even the touchpad did not respond anymore, so I switched back to libinput)

To me this seems like a strange problem with the Xorg driver, but I cannot figure out what's wrong.

Using evtest I found out that the touchscreen sends signals as long as the Xserver of the Gnome/Ubuntu session is not started yet. After that it does not send signals anymore.

The fact that I had the touchscreen working during the first session makes me quite sure that there should be a fix for this, or at least a workaround. Maybe there are some configuration files that were created during the first start of the Gnome/Ubuntu session? I tried to remove ~./config/dconf/user, but this did not help. Are there any others? Is there another Xorg driver that I could try?

Just to add some more information I append the relevant part of my Xorg.log here:

[    17.425] (II) config/udev: Adding input device SYNAPTICS Synaptics Touch Digitizer V04 Mouse (/dev/input/event4)  
[    17.425] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: Applying InputClass "libinput pointer catchall"  
[    17.425] (II) Using input driver 'libinput' for 'SYNAPTICS Synaptics Touch Digitizer V04 Mouse'  
[    17.483] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 31 paused 0  
[    17.484] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: always reports core events  
[    17.484] (**) Option "Device" "/dev/input/event4"  
[    17.484] (**) Option "_source" "server/udev"  
[    17.487] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: is tagged by udev as: Mouse  
[    17.487] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: device is a pointer  
[    17.488] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: device removed  
[    17.488] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-8/1-8:1.0/0003:06CB:16F9.0001/input/input13/event4"  
[    17.488] (II) XINPUT: Adding extended input device "SYNAPTICS Synaptics Touch Digitizer V04 Mouse" (type: MOUSE, id 10)  
[    17.488] (**) Option "AccelerationScheme" "none"  
[    17.488] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: (accel) selected scheme none/0  
[    17.488] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: (accel) acceleration factor: 2.000  
[    17.488] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: (accel) acceleration threshold: 4  
[    17.490] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: is tagged by udev as: Mouse  
[    17.490] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: device is a pointer  
[    17.491] (II) config/udev: Adding input device SYNAPTICS Synaptics Touch Digitizer V04 Mouse (/dev/input/mouse0)  
[    17.491] (II) No input driver specified, ignoring this device.  
[    17.491] (II) This device may have been added with another device file.  
[    17.492] (II) config/udev: Adding input device SYNAPTICS Synaptics Touch Digitizer V04 (/dev/input/event5)  
[    17.492] (**) SYNAPTICS Synaptics Touch Digitizer V04: Applying InputClass "libinput touchscreen catchall"  
[    17.492] (II) Using input driver 'libinput' for 'SYNAPTICS Synaptics Touch Digitizer V04'  
[    17.493] (II) systemd-logind: got fd for /dev/input/event5 13:69 fd 32 paused 0  
[    17.493] (**) SYNAPTICS Synaptics Touch Digitizer V04: always reports core events  
[    17.493] (**) Option "Device" "/dev/input/event5"  
[    17.493] (**) Option "_source" "server/udev"  
[    17.496] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: is tagged by udev as: Touchscreen  
[    17.496] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: device is a touch device  
[    17.496] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: device removed  
[    17.496] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-8/1-8:1.0/0003:06CB:16F9.0001/input/input14/event5"  
[    17.496] (II) XINPUT: Adding extended input device "SYNAPTICS Synaptics Touch Digitizer V04" (type: TOUCHSCREEN, id 11)  
[    17.496] (**) Option "AccelerationScheme" "none"  
[    17.496] (**) SYNAPTICS Synaptics Touch Digitizer V04: (accel) selected scheme none/0  
[    17.496] (**) SYNAPTICS Synaptics Touch Digitizer V04: (accel) acceleration factor: 2.000  
[    17.497] (**) SYNAPTICS Synaptics Touch Digitizer V04: (accel) acceleration threshold: 4  
[    17.499] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: is tagged by udev as: Touchscreen  
[    17.499] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: device is a touch device  
[    17.500] (II) config/udev: Adding input device SYNAPTICS Synaptics Touch Digitizer V04 (/dev/input/mouse1)  
[    17.500] (II) No input driver specified, ignoring this device.  
[    17.500] (II) This device may have been added with another device file.  

Best Answer

  • Sorry I'm quite new here an can't comment on your post yet as it's not unlocked yet.

    But i face the very similiar issue with Ubuntu 20.04 and Gnome 3.36.1 with the HP spectre x360 13-4203ng in my case.

    I welcome any kind of help or idea or request to debug and find the issue, as i'd really like to have the touchscreen working again.

    Thanks for all your support - Jack

  • Related Question