Ubuntu – Unable to install latest brackets on Ubuntu 15.04

15.04software installation

I have latest deb package of brackets 64bit. I am on Ubuntu 15.04. I am getting the following error:

dependency is not satisfiable: libgcrypt11 (>= 1.4.5)

I tried to install libgcrypt11 then I got this error:

$ sudo apt-get install libgcrypt11
Package libgcrypt11 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'libgcrypt11' has no installation candidate

What should I do now?

Best Answer

Update, the version below is not longer available. Now you have to install the Trusty version:

wget https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa/+build/7110687/+files/libgcrypt11_1.5.4-2ubuntu1.1_amd64.deb
sudo dpkg -i libgcrypt11_1.5.4-2ubuntu1.1_amd64.deb

The package libgcrypt11 isn't longer an installable package in Ubuntu 15.04. You need now the library libgcrypt20.

Therefore install the latest Utopic package from here with:

sudo dpkg -i libgcrypt11_1.5.4-2ubuntu1.1_amd64.deb

Or follow the steps from my previous answer to change the dependencies for the brackets package and use libgcrypt20.