Ubuntu – Unable to install vlc media player in ubuntu 16.04 LTS

16.04aptdependenciesvlc

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
vlc : Depends: vlc-nox (= 2.2.2+git20160830+r58831+56~ubuntu16.04.1) but it is not going to be installed
   Depends: libavcodec-ffmpeg56 (>= 7:2.4) but it is not going to be installed or
            libavcodec-ffmpeg-extra56 (>= 7:2.4) but it is not going to be installed
   Depends: libavutil-ffmpeg54 (>= 7:2.4) but it is not going to be installed
   Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
            libgles1
   Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or
            libgles2
   Depends: libqt5x11extras5 (>= 5.1.0) but it is not going to be installed
   Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
   Depends: libsdl1.2debian (>= 1.2.11) but it is not going to be installed
   Depends: libva-drm1 (>= 1.1.0) but it is not going to be installed
   Depends: libva-x11-1 (>= 1.0.3) but it is not going to be installed
   Depends: libva1 (>= 1.2.0) but it is not going to be installed
   Depends: libvlccore8 (>= 2.2.0) but it is not going to be installed
   Depends: libxcb-composite0 but it is not going to be installed
   Depends: libxcb-xv0 (>= 1.2) but it is not going to be installed
   Recommends: vlc-plugin-notify (= 2.2.2+git20160830+r58831+56~ubuntu16.04.1) but it is not going to be installed
   Recommends: vlc-plugin-samba (= 2.2.2+git20160830+r58831+56~ubuntu16.04.1) but it is not going to be installed
   Conflicts: vlc:i386 but 2.1.4-1 is to be installed
vlc:i386 : Depends: vlc-nox:i386 (= 2.1.4-1) but it is not going to be installed
        Depends: libaa1:i386 (>= 1.4p5) but it is not going to be installed
        Depends: libc6:i386 (>= 2.15) but it is not going to be installed
        Depends: libcaca0:i386 (>= 0.99.beta17-1) but it is not going to be installed
        Depends: libfreetype6:i386 (>= 2.2.1) but it is not going to be installed
        Depends: libfribidi0:i386 (>= 0.19.2) but it is not going to be installed
        Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
        Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
                 libgl1:i386
        Depends: libqtcore4:i386 (>= 4:4.8.0) but it is not going to be installed
        Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
        Depends: libsdl-image1.2:i386 (>= 1.2.10) but it is not going to be installed
        Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not going to be installed
        Depends: libstdc++6:i386 (>= 4.6) but it is not going to be installed
        Depends: libtar0:i386 but it is not going to be installed
        Depends: libva-x11-1:i386 (> 1.3.0~) but it is not going to be installed
        Depends: libva1:i386 (> 1.3.0~) but it is not going to be installed
        Depends: libvlccore7:i386 (>= 2.1.0) but it is not installable
        Depends: libx11-6:i386 but it is not going to be installed
        Depends: libxcb-composite0:i386 but it is not going to be installed
        Depends: libxcb-keysyms1:i386 (>= 0.3.9) but it is not going to be installed
        Depends: libxcb-randr0:i386 (>= 1.1) but it is not going to be installed
        Depends: libxcb-shm0:i386 but it is not going to be installed
        Depends: libxcb-xv0:i386 (>= 1.2) but it is not going to be installed
        Depends: libxcb1:i386 (>= 1.6) but it is not going to be installed
        Depends: libxext6:i386 but it is not going to be installed
        Depends: libxinerama1:i386 but it is not going to be installed
        Depends: libxpm4:i386 but it is not going to be installed
        Depends: zlib1g:i386 (>= 1:1.2.3.3) but it is not going to be installed
        Recommends: vlc-plugin-notify:i386 (= 2.1.4-1) but it is not going to be installed
        Recommends: vlc-plugin-pulse:i386 (= 2.1.4-1) but it is not installable
        Conflicts: vlc but 2.2.2+git20160830+r58831+56~ubuntu16.04.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I have tried eveything -f -f install

But nothing seems to work.
this is not all when ever i try sudo apt upgrade

I get the following error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 vlc:i386 : Depends: vlc-nox:i386 (= 2.1.4-1) but it is not installed
            Depends: libaa1:i386 (>= 1.4p5) but it is not installed
            Depends: libc6:i386 (>= 2.15) but it is not installed
            Depends: libcaca0:i386 (>= 0.99.beta17-1) but it is not installed
            Depends: libfreetype6:i386 (>= 2.2.1) but it is not installed
            Depends: libfribidi0:i386 (>= 0.19.2) but it is not installed
            Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
            Depends: libgl1-mesa-glx:i386 but it is not installed or
                     libgl1:i386
            Depends: libqtcore4:i386 (>= 4:4.8.0) but it is not installed
            Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not installed
            Depends: libsdl-image1.2:i386 (>= 1.2.10) but it is not installed
            Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not installed
            Depends: libstdc++6:i386 (>= 4.6) but it is not installed
            Depends: libtar0:i386 but it is not installed
            Depends: libva-x11-1:i386 (> 1.3.0~) but it is not installed
            Depends: libva1:i386 (> 1.3.0~) but it is not installed
            Depends: libvlccore7:i386 (>= 2.1.0) but it is not installable
            Depends: libx11-6:i386 but it is not installed
            Depends: libxcb-composite0:i386 but it is not installed
            Depends: libxcb-keysyms1:i386 (>= 0.3.9) but it is not installed
            Depends: libxcb-randr0:i386 (>= 1.1) but it is not installed
            Depends: libxcb-shm0:i386 but it is not installed
            Depends: libxcb-xv0:i386 (>= 1.2) but it is not installed
            Depends: libxcb1:i386 (>= 1.6) but it is not installed
            Depends: libxext6:i386 but it is not installed
            Depends: libxinerama1:i386 but it is not installed
            Depends: libxpm4:i386 but it is not installed
            Depends: zlib1g:i386 (>= 1:1.2.3.3) but it is not installed
            Recommends: vlc-plugin-notify:i386 (= 2.1.4-1) but it is not installed
            Recommends: vlc-plugin-pulse:i386 (= 2.1.4-1) but it is not installable
E: Unmet dependencies. Try using -f.

I have tried even the -f but nothing happens still.

Please Help

Best Answer

  • The Only Solution to this problem is adding padoka mesa stable repository..

    https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/pkppa

    Then run

    sudo apt-get install vlc
    

    It will Work Surely As the above repository have both libgles1-mesa and libgles2-mesa required for vlc..

  • Related Question