Ubuntu – Unmet dependencies in Ubuntu 12.04

12.04aptcodecsdependenciessoftware-sources

The following packages have unmet dependencies:
       gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7-1) but    4:0.7.2.1ubuntu2 is to be installed
                         Depends: libavformat-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libavutil-extra-51 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                         Depends: libglib2.0-0 (>= 2.24.0) but 2.32.3-0ubuntu1 is to be installed
                         Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                         Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                         Depends: liborc-0.4-0 (>= 1:0.4.14) but 1:0.4.16-1ubuntu2 is to be installed
                         Depends: libpostproc-extra-52 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libswscale-extra-2 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed gstreamer0.10-ffmpeg:i386:    Depends: libavcodec-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to   be installed
                              Depends: libavformat-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libavutil-extra-51 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                              Depends: libglib2.0-0 (>= 2.24.0) but 2.32.3-0ubuntu1 is to be installed
                              Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                              Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                              Depends: liborc-0.4-0 (>= 1:0.4.14) but 1:0.4.16-1ubuntu2 is to be installed
                              Depends: libpostproc-extra-52 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libswscale-extra-2 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed



       Package dependencies cannot be resolved
       This error could be caused by required additional software packages    which are missing or not installable. Furthermore there could be a    conflict between software packages which are not allowed to be    installed at the same time.

I have tried to follow every instruction from here and it has still not helped me.

What is the problem and how do I fix it ?

Edit:
My problem is that I can't install Gstreamer ffmpeg video plug-in
codecs to play .mpeg, .divx, .mpeg4, .ac3, .wmv and .asf files

Best Answer

  • You appear to be using very outdated libraries, for example "libavcodec-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed". That version was released in 12.04 dev on 2011-12-26 and has been Superseded numerous times.

    The current 12.04 version is 4:0.8.3ubuntu0.12.04.1) precise-security

    So open software sources, software-properties-gtk & make sure that under Ubuntu Software the 1st 4 are checked & under Updates the 1st. 2 are checked

    Then update your sources & see

  • Related Question