Ubuntu – Version `SAMBA_UTIL_0.0.1′ not found on Kubuntu 20.10

aptsambasoftware installation

My samba libraries appear to be missing, even though I know that everything is up to date.
I'm running Kubuntu 20.10.

Here is the terminal output:

priz@prizmatic:~$ sudo apt install samba-libs -y
Reading package lists... Done
Building dependency tree       
Reading state information... Done
samba-libs is already the newest version (2:4.12.5+dfsg-3ubuntu4.1).
samba-libs set to manually installed.
The following packages were automatically installed and are no longer required:
  libipa-hbac0 libkf5konq-data libkf5konq6
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up samba-common-bin (2:4.12.5+dfsg-3ubuntu4.1) ...
Checking smb.conf with testparm
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by testparm)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /lib/x86_64-linux-gnu/libsmbconf.so.0)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /usr/lib/x86_64-linux-gnu/samba/libpopt-samba3.so.0)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /usr/lib/x86_64-linux-gnu/samba/libsamba-sockets.so.0)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /usr/lib/x86_64-linux-gnu/samba/libserver-id-db.so.0)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /usr/lib/x86_64-linux-gnu/samba/libutil-reg.so.0)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /usr/lib/x86_64-linux-gnu/samba/libCHARSET3.so.0)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /usr/lib/x86_64-linux-gnu/samba/libmessages-util.so.0)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /usr/lib/x86_64-linux-gnu/samba/libdbwrap.so.0)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /lib/x86_64-linux-gnu/libndr.so.1)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /usr/lib/x86_64-linux-gnu/samba/libsamba-security.so.0)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /usr/lib/x86_64-linux-gnu/samba/libmessages-dgm.so.0)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /lib/x86_64-linux-gnu/libsamba-hostconfig.so.0)
testparm: /usr/lib/x86_64-linux-gnu/samba/libsamba-util.so.0: version `SAMBA_UTIL_0.0.1' not found (required by /lib/x86_64-linux-gnu/libndr-nbt.so.0)
dpkg: error processing package samba-common-bin (--configure):
 installed samba-common-bin package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of samba:
 samba depends on samba-common-bin (= 2:4.12.5+dfsg-3ubuntu4.1); however:
  Package samba-common-bin is not configured yet.

dpkg: error processing package samba (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of winbind:
 winbind depends on samba-common-bin (= 2:4.12.5+dfsg-3ubuntu4.1); however:
  Package samba-common-bin is not configured yet.

dpkg: error processing package winbind (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 samba-common-bin
 samba
 winbind
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can anybody let me know what I have to install to get samba working?
What I believe is happening is that the installer is checking if some files exist, and if they do it doesn't try to copy the rest. However, that leaves some package or file missing which indicates that SAMBA_UTIL_0.0.1 is present, or maybe that the newer packages no longer have some files

Best Answer

Yes, my suspicions were correct, the Groovy archives contain a new version that do not have some files but are required. Installing the latest from the Focal archives, then updating fixed the issue.

Here is the command I ran

sudo apt install libsmbclient=2:4.11.6+dfsg-0ubuntu1.6 libsmbios-c2=2.4.3-1 python3-samba=2:4.11.6+dfsg-0ubuntu1.6 samba-common-bin=2:4.11.6+dfsg-0ubuntu1.6 samba-common=2:4.11.6+dfsg-0ubuntu1.6 samba-dsdb-modules=2:4.11.6+dfsg-0ubuntu1.6 samba-libs=2:4.11.6+dfsg-0ubuntu1.6 samba-vfs-modules=2:4.11.6+dfsg-0ubuntu1.6 samba=2:4.11.6+dfsg-0ubuntu1.6 smbclient=2:4.11.6+dfsg-0ubuntu1.6 libwbclient0=2:4.11.6+dfsg-0ubuntu1.6 libldb2=2:2.0.10-0ubuntu0.20.04.2 python3-ldb=2:2.0.10-0ubuntu0.20.04.2

Then run sudo apt upgrade -y to upgrade everything.