Ubuntu – Virtualbox upgrade error “Breaks existing package…”

dependenciesupgradevirtualbox

Trying to upgrade from Virtualbox 4.2 to 4.3, receiving error

"Breaks existing package 'virtualbox-4.2' that conflict: 'virtualbox'..."

Best Answer

In order to be able to upgrade Virtual Box to a higher major release (e.g. 4.2.x to 4.3.x) we will have to remove the kernel modules and applications of an old version first. This will not affect our virtual machines.

In case you had installed from the Oracle repository you can - after having updated the apt cache - just run the following commands:

sudo apt-get purge virtualbox-4.2
sudo apt-get install virtualbox-4.3

After upgrading we will also have to download and re-install the extension packs in case we need them. Also it is advisable to update the guest additions in our virtual machines.