Ubuntu – VK_ERROR_INCOMPATIBLE_DRIVER error with Vulkan on ATI Sapphire 7870 running (X)Ubuntu 18.04

amd-graphicsdriversradeonvulkan

I spent +- 22 hours trying to make it work, but I find more problems than solutions.

PROBLEM

Steps to reproduce #1

SHORTED, MORE IN ORIGINAL DOC.

INFORMATION

  • GPU: ATI Sapphire 7870 AND AMD Radeon 7870AMD/ATI

  • OS: Tested on Debian 9, Xubuntu and Ubuntu.

    • Right now I have fresh installation of Ubuntu with backup using Clonezilla and basic setup.

    • apt list –installed > /home/kreyren/Desktop/Installed_packages.txt
      https://pastebin.com/WrKWWbhg

    • Installed updates using sudo apt-get update -y && sudo apt-get upgrade -y && sudo apt-get dist-upgrade -y

    • Distro has 20GB of root + 2GB swap on SSD and 100GB of /home on HDD

    • Verify that it's supported by AMD:

TRIED SOLUTION

  • add NAND modify /etc/X11/xorg.conf with

    Section "Device"
        Identifier "AMD"
        Driver "amdgpu"
        Option "TearFree" "true"
    EndSection
    
  • Reboot > VK_ERROR_INCOMPATIBLE_DRIVER

SHORTED, MORE IN ORIGINAL DOC.

BACKSTORY

Original is available on personal Google docs.

I made Facebook document where I tried to fix this issue with the help of other Linux users. Facebook document was removed after solution and the issue was posted on askubuntu! Hoping to reach more people with same issue.

Not enough reputation to post rest of the original and it seems pointless to spam with irelevant info, its here for those who are interested in this issue like Developers who could possibly fix this issue by default.

Best Answer

This solution may be outdated. It seems that only mesa-vulkan-driver and sudo apt dist-upgrade is needed to make vulkan API work. - Updated 10/07/2018

I found the solution before i posted this answer this is repost recommended by @ElderGeek on forum. (•̀ᴗ•́)و

Vulkan installation on AMD Radeon 7870 running Ubuntu 18.04 (possible other debian-based distros)

NOTE: I wasn't able to reproduce it on Debian 9.4.

WARNING: Grab a backup since systemd (or its alternatives) won't be able to boot with error something like: ERR: Install firmware-amd-graphics package.

WARNING_EDIT: It seems that package firmware-amd-graphics is now installd by default on Ubuntu 18.04. I noticed the change at 10/07/2018.

  1. Run this command to update your system

    sudo apt-get update -y && sudo apt-get upgrade -y
    
  2. Install Mesa Vulkan Drivers:

    sudo apt-get install mesa-vulkan-drivers vulkan-utils
    
  3. Modify kernel parameters in /etc/default/grub as:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.si_support=0 amdgpu.si_support=1 modprobe.blacklist=radeon"
    

    This should fix VK_ERROR_INCOMPATIBLE_DRIVER.

  4. To switch on amdgpu driver. (radeon's not working with this GPU.)

  5. Run these commands:

    • sudo update-grub To update grub based on info in /etc/default/grub .
    • sudo shutdown -r now To restart your device.
    • lspci -k | grep "Kernel driver in use:" To verify that it's loaded correctly, output should be: "Kernel driver in use: amdgpu".
  6. Should show up in vulkaninfo without problems.


In case it doesn't work

  1. Add nor modify /etc/X11/xorg.conf AND /etc/X11/20-amdgpu.conf with the following content (reboot after this modifications):

    Section "Device"
        Identifier "AMD"
        Driver "amdgpu"
        Option "TearFree" "true"
    EndSection
    
    • Option "TearFree" "true" should fix problem with screen thearing.
  2. Verify that amdgpu is loaded by loading GRUB and pressing E.

  3. sudo usermod -a -G video $LOGNAME

  4. sudo apt-get install hexchat > join #radeon and ask for help.

Feel free to share your experience I'm willing to update this post. (☞゚ヮ゚)☞