Ubuntu – VLC fails to install on 14.04

14.04dependenciesvlc

I'm (desperately) trying to install VLC on my 14.04.

apt-cache policy vlc

returns:

vlc:
  Installed: (none)
  Candidate: 2.1.6-0ubuntu14.04.1
  Version table:
     2.1.6-0ubuntu14.04.1 0
        500 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty-updates/universe amd64 Packages
        500 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty-security/universe amd64 Packages
     2.1.2-2build2 0
        500 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe amd64 Packages

When I try to install, then I get the infamous vlc-nox issue:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 vlc : Depends: vlc-nox (= 2.1.6-0ubuntu14.04.1) but it is not going to be installed
       Recommends: vlc-plugin-notify (= 2.1.6-0ubuntu14.04.1) but it is not going to be installed
       Recommends: vlc-plugin-pulse (= 2.1.6-0ubuntu14.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Attempt to install vlc-nox leads to request of installation of libfreerdp1, and then to this message:

sudo apt-get install libfreerdp1

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  freerdp-x11
The following packages will be REMOVED
  libfreerdp-cache1.1 libfreerdp-client1.1 libfreerdp-codec1.1
  libfreerdp-common1.1.0 libfreerdp-core1.1 libfreerdp-crypto1.1
  libfreerdp-gdi1.1 libfreerdp-locale1.1 libfreerdp-plugins-standard
  libfreerdp-primitives1.1 libfreerdp-rail1.1 libfreerdp-utils1.1
  libwinpr-crt0.1 libwinpr-dsparse0.1 libwinpr-environment0.1 libwinpr-file0.1
  libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1
  libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1
  libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1 libwinpr-sspi0.1
  libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1
  libxfreerdp-client1.1 remmina-plugin-rdp
The following NEW packages will be installed
  libfreerdp1

Now, I don't understand why vlc installation would lead to removing these packages? Is there any way around this issue?

Already went through (reasonable) solutions suggested here, here, here, here, here apart from adding repositories.


Output of apt-cache policy libfreerdp-cache1.1:

libfreerdp-cache1.1:
  Installed: 1.1.0~git20140921.1.440916e+dfsg1-2ubuntu1~trusty1
  Candidate: 1.1.0~git20140921.1.440916e+dfsg1-2ubuntu1~trusty1
  Version table:
 *** 1.1.0~git20140921.1.440916e+dfsg1-2ubuntu1~trusty1 0
        500 http://ppa.launchpad.net/remmina-ppa-team/remmina-master/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

Output of apt-cache policy remmina-plugin-rdp:

remmina-plugin-rdp:
  Installed: 1.1.1-ppa1+484+201508180831~ubuntu14.04.1
  Candidate: 1.1.1-ppa1+484+201508180831~ubuntu14.04.1
  Version table:
 *** 1.1.1-ppa1+484+201508180831~ubuntu14.04.1 0
        500 http://ppa.launchpad.net/remmina-ppa-team/remmina-master/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.0-4ubuntu3 0
        500 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/main amd64 Packages

Best Answer

  • The first part of your problem is that you have disabled unstable PPAs or repos. Please take a look at this post for additional information. This would be the first step in solving your issue.

    After you cleared up that, please enter the following into a Terminal window.

     sudo apt-get remove --purge vlc-nox
     sudo apt-get autoclean
     sudo dpkg --configure -a
     sudo apt-get -f install
     sudo apt-get autoremove
     sudo apt-get update
     sudo apt-get dist-upgrade
     sudo apt-get install vlc
    

    Another recommendation would be using the official VLC repo than the Ubuntu one. These are kept up to date and are a lot more efficient in my opinion. If you want to do that, please enter the following below:

     sudo add-apt-repository ppa:videolan/stable-daily
     sudo apt-get update && sudo apt-get upgrade
     sudo apt-get install vlc