Ubuntu – Which TLS protocols are enabled in Ubuntu 14.04’s OpenSSL

openssltls

This is a follow up to Override Distro Package with Custom Package?.

Does anyone know if Ubuntu 14.04's OpenSSL enables all TLS protocols (TLS1.0, TLS1.1 and TLS1.2)? Or does it have protocols disabled (TLS1.1 and TLS1.2) like past versions?

Related: how does one even check for this sort of thing?

Edit: This is not a bug report question; nor is it a developer question. You guys are taking the "Close as Bug Report" much too far.

Best Answer

  • $ cat /etc/issue
    Ubuntu 14.04 LTS \n \l
    
    $ apt-cache policy openssl
    openssl:
      Installed: 1.0.1f-1ubuntu2
      Candidate: 1.0.1f-1ubuntu2
      Version table:
     *** 1.0.1f-1ubuntu2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
            100 /var/lib/dpkg/status
    
    $ openssl ciphers -v 'TLSv1.2' | head -4
    ECDHE-RSA-AES256-GCM-SHA384 TLSv1.2 Kx=ECDH     Au=RSA  Enc=AESGCM(256) Mac=AEAD
    ECDHE-ECDSA-AES256-GCM-SHA384 TLSv1.2 Kx=ECDH     Au=ECDSA Enc=AESGCM(256) Mac=AEAD
    ECDHE-RSA-AES256-SHA384 TLSv1.2 Kx=ECDH     Au=RSA  Enc=AES(256)  Mac=SHA384
    ECDHE-ECDSA-AES256-SHA384 TLSv1.2 Kx=ECDH     Au=ECDSA Enc=AES(256)  Mac=SHA384