Ubuntu – WiFi DELL XPS 13 9360 keeps disconnecting with QCA6174 802.11ac Wireless Network Adapter

16.04atherosdellfirmwarewireless

I have a dual boot (in insecure mode) DELL XPS 13 9360 with windows 10 and Ubuntu 16.04. I loose my internet connection over WiFi in Ubuntu. It says I still have a WiFi connection, but when I try to load a web page it does not work. Upon reconnecting the WiFi it works again.

I haven't noticed any problems under Windows, but I also don't use it that often.

I get the following error messages:

$ dmesg | grep ath10k
[    4.205120] ath10k_pci 0000:3a:00.0: enabling device (0000 -> 0002)
[    4.208595] ath10k_pci 0000:3a:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
[    4.451852] ath10k_pci 0000:3a:00.0: Direct firmware load for ath10k/cal-pci-0000:3a:00.0.bin failed with error -2
[    4.452298] ath10k_pci 0000:3a:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
[    4.452302] ath10k_pci 0000:3a:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
[    6.685390] ath10k_pci 0000:3a:00.0: qca6174 hw3.2 (0x05030000, 0x00340aff sub 1a56:1535) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 fwapi 4 bdapi 2 htt-ver 3.26 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features wowlan,ignore-otp,no-4addr-pad
[    6.685394] ath10k_pci 0000:3a:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[    6.770465] ath10k_pci 0000:3a:00.0 wlp58s0: renamed from wlan0
[   31.785831]  drbg ansi_cprng ctr ccm arc4 rfcomm ax88179_178a usbnet mii bnep hid_multitouch i2c_designware_platform i2c_designware_core dell_wmi dell_laptop dcdbas snd_hda_codec_hdmi dell_led nls_iso8859_1 snd_hda_codec_realtek snd_hda_codec_generic x86_pkg_temp_thermal coretemp kvm_intel kvm irqbypass crct10dif_pclmul crc32_pclmul snd_hda_intel ghash_clmulni_intel snd_hda_codec snd_hda_core snd_hwdep snd_pcm aesni_intel snd_seq_midi snd_seq_midi_event snd_rawmidi aes_x86_64 lrw gf128mul snd_seq glue_helper snd_seq_device ablk_helper ath10k_pci snd_timer cryptd ath10k_core ath mac80211 serio_raw snd soundcore cfg80211 uvcvideo rtsx_pci_ms videobuf2_vmalloc memstick videobuf2_memops videobuf2_v4l2 videobuf2_core v4l2_common input_leds joydev videodev media btusb idma64 btrtl virt_dma mei_me mei shpchp
[  333.016018] ath10k_pci 0000:3a:00.0: failed to stop wmi scan: -11
[  333.016023] ath10k_pci 0000:3a:00.0: failed to stop scan: -11
[  333.016025] ath10k_pci 0000:3a:00.0: failed to start hw scan: -110
[  337.016326] ath10k_pci 0000:3a:00.0: failed to start hw scan: -11
[  341.016440] ath10k_pci 0000:3a:00.0: failed to start hw scan: -11
[  342.066875] ath10k_pci 0000:3a:00.0: firmware crashed! (uuid 62bfa4a8-1fa3-4e94-9aba-362b8e591c7b)
[  342.066947] ath10k_pci 0000:3a:00.0: qca6174 hw3.2 (0x05030000, 0x00340aff sub 1a56:1535) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 fwapi 4 bdapi 2 htt-ver 3.26 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features wowlan,ignore-otp,no-4addr-pad
[  342.066964] ath10k_pci 0000:3a:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[  342.068995] ath10k_pci 0000:3a:00.0: firmware register dump:
[  342.069013] ath10k_pci 0000:3a:00.0: [00]: 0x05030000 0x000015B3 0x009860FA 0x00955B31
[  342.069021] ath10k_pci 0000:3a:00.0: [04]: 0x009860FA 0x00060730 0x00000004 0x0040E8A0
[  342.069027] ath10k_pci 0000:3a:00.0: [08]: 0x00498110 0x00955A00 0x0000000B 0x00400000
[  342.069033] ath10k_pci 0000:3a:00.0: [12]: 0x00000009 0x00000000 0x00952CD0 0x00952CE6
[  342.069039] ath10k_pci 0000:3a:00.0: [16]: 0x00952CC4 0x0091080D 0x00000000 0x0091080D
[  342.069047] ath10k_pci 0000:3a:00.0: [20]: 0x409860FA 0x0040E7E8 0x00000000 0x0041E0DC
[  342.069057] ath10k_pci 0000:3a:00.0: [24]: 0x800B5A1D 0x0040E848 0x000FFFFF 0xC09860FA
[  342.069064] ath10k_pci 0000:3a:00.0: [28]: 0x809B3230 0x0040E948 0x00000018 0x004313DC
[  342.069070] ath10k_pci 0000:3a:00.0: [32]: 0x809B2992 0x0040E998 0x0040E9C0 0x00429548
[  342.069077] ath10k_pci 0000:3a:00.0: [36]: 0x8091D252 0x0040E9B8 0x00000000 0x00000002
[  342.069083] ath10k_pci 0000:3a:00.0: [40]: 0x809FF05D 0x0040EA68 0x0043A380 0x00429C10
[  342.069089] ath10k_pci 0000:3a:00.0: [44]: 0x809FCFDB 0x0040EA88 0x0043A380 0x00000001
[  342.069096] ath10k_pci 0000:3a:00.0: [48]: 0x80911210 0x0040EAD8 0x00000010 0x004041D0
[  342.069102] ath10k_pci 0000:3a:00.0: [52]: 0x80911154 0x0040EB28 0x00400000 0x00000000
[  342.069109] ath10k_pci 0000:3a:00.0: [56]: 0x8091122D 0x0040EB48 0x00000000 0x00400600
[  342.069203] ath10k_pci 0000:3a:00.0: failed to start hw scan: -108
[  344.512357] ath10k_pci 0000:3a:00.0: device successfully recovered
[ 2346.814762]  drbg ansi_cprng ctr ccm arc4 rfcomm ax88179_178a usbnet mii bnep hid_multitouch i2c_designware_platform i2c_designware_core dell_wmi dell_laptop dcdbas snd_hda_codec_hdmi dell_led nls_iso8859_1 snd_hda_codec_realtek snd_hda_codec_generic x86_pkg_temp_thermal coretemp kvm_intel kvm irqbypass crct10dif_pclmul crc32_pclmul snd_hda_intel ghash_clmulni_intel snd_hda_codec snd_hda_core snd_hwdep snd_pcm aesni_intel snd_seq_midi snd_seq_midi_event snd_rawmidi aes_x86_64 lrw gf128mul snd_seq glue_helper snd_seq_device ablk_helper ath10k_pci snd_timer cryptd ath10k_core ath mac80211 serio_raw snd soundcore cfg80211 uvcvideo rtsx_pci_ms videobuf2_vmalloc memstick videobuf2_memops videobuf2_v4l2 videobuf2_core v4l2_common input_leds joydev videodev media btusb idma64 btrtl virt_dma mei_me mei shpchp
[ 4457.132991] ath10k_pci 0000:3a:00.0: failed to stop wmi scan: -11
[ 4457.132998] ath10k_pci 0000:3a:00.0: failed to stop scan: -11
[ 4457.133002] ath10k_pci 0000:3a:00.0: failed to start hw scan: -110
[ 4461.133068] ath10k_pci 0000:3a:00.0: failed to start hw scan: -11
[ 4465.133108] ath10k_pci 0000:3a:00.0: failed to start hw scan: -11
[ 4466.258813] ath10k_pci 0000:3a:00.0: firmware crashed! (uuid 04fb9fb0-095b-4470-8de4-7228e15e1861)
[ 4466.258832] ath10k_pci 0000:3a:00.0: qca6174 hw3.2 (0x05030000, 0x00340aff sub 1a56:1535) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 fwapi 4 bdapi 2 htt-ver 3.26 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features wowlan,ignore-otp,no-4addr-pad
[ 4466.258836] ath10k_pci 0000:3a:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[ 4466.260838] ath10k_pci 0000:3a:00.0: firmware register dump:
[ 4466.260845] ath10k_pci 0000:3a:00.0: [00]: 0x05030000 0x000015B3 0x009860FA 0x00955B31
[ 4466.260848] ath10k_pci 0000:3a:00.0: [04]: 0x009860FA 0x00060730 0x00000004 0x0040E8A0
[ 4466.260855] ath10k_pci 0000:3a:00.0: [08]: 0x00498110 0x00955A00 0x0000000B 0x00400000
[ 4466.260857] ath10k_pci 0000:3a:00.0: [12]: 0x00000009 0x00000000 0x00952CD0 0x00952CE6
[ 4466.260859] ath10k_pci 0000:3a:00.0: [16]: 0x00952CC4 0x00910712 0x00000000 0x0091080D
[ 4466.260861] ath10k_pci 0000:3a:00.0: [20]: 0x409860FA 0x0040E7E8 0x00000000 0x0041E0DC
[ 4466.260863] ath10k_pci 0000:3a:00.0: [24]: 0x800B5A1D 0x0040E848 0x000FFFFF 0xC09860FA
[ 4466.260864] ath10k_pci 0000:3a:00.0: [28]: 0x809B3230 0x0040E948 0x00000018 0x004313DC
[ 4466.260866] ath10k_pci 0000:3a:00.0: [32]: 0x809B2992 0x0040E998 0x0040E9C0 0x00429548
[ 4466.260869] ath10k_pci 0000:3a:00.0: [36]: 0x8091D252 0x0040E9B8 0x00000000 0x00000002
[ 4466.260873] ath10k_pci 0000:3a:00.0: [40]: 0x809FF05D 0x0040EA68 0x0043A380 0x00429C10
[ 4466.260877] ath10k_pci 0000:3a:00.0: [44]: 0x809FCFDB 0x0040EA88 0x0043A380 0x00000001
[ 4466.260881] ath10k_pci 0000:3a:00.0: [48]: 0x80911210 0x0040EAD8 0x00000010 0x004041D0
[ 4466.260883] ath10k_pci 0000:3a:00.0: [52]: 0x80911154 0x0040EB28 0x00400000 0x00000000
[ 4466.260885] ath10k_pci 0000:3a:00.0: [56]: 0x8091122D 0x0040EB48 0x00000000 0x00400600
[ 4466.260928] ath10k_pci 0000:3a:00.0: failed to start hw scan: -108
[ 4468.699722] ath10k_pci 0000:3a:00.0: device successfully recovered

I've tried reinstalling the drivers from the hw3.0 folder from here.

Also you can find the wireless-info log here, taken just after another crash.

Best Answer

  • I would disable wifi power management with

    sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

    Change the encryption on the wireless router to WPA2 only with no WEP, TKIP or plain WPA, depending on the router it may be called WPA2-PSK, WPA2-AES or WPA2 Personal.

    Reinstall the linux-firmware package

    sudo apt-get install --reinstall linux-firmware

    Reboot

  • Related Question