Ubuntu – WiFi doesn’t work with Compaq CQ58 (RALINK RT5390R)

18.04driverslubuntunetworking

After going around all the forums looking for answers and help, having tested all I read on my circa-2012 Compaq CQ58 (with no success), I'm here to ask you help.

For days I installed versions and versions of Ubuntu and Lubuntu trying to make WiFi work well, but it doesn't. Currently I have installed Lubuntu 18.04 LTS (system requirements) and it doesn't work here either.

I will briefly explain the problem: when I turn on my PC the WiFi connects and for a minute the pages loads and everything goes very quickly but after a minute (or even less) despite the connection there is and despite I have Internet on my phone; on the computer it does not work anymore. The pages do not load and the WiFi tends to disconnect and change networks without being able to establish a connection, no longer allowing me to browse.

I thought it was a drivers problem and then I looked for the drivers for my WiFi module (Ralink RT5390R 802.11bgn PCIe), but I did not found them loadable for Linux… I found only for Windows and with all the codes that I found I had no results, often i've gotPL code errors and other problems.

Can you help me? I don't know what to do. If you need details let me know …
i'm adding some outputs:

02:00.0 Network controller [0280]: Ralink corp. RT5390R 802.11bgn PCIe Wireless Network Adapter [1814:539b]
    Subsystem: Hewlett-Packard Company RT5390R 802.11bgn PCIe Wireless Network Adapter [103c:18ed]
    Kernel driver in use: rt2800pci
    Kernel modules: rt2800pci
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader [10ec:5229] (rev 01)
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no


Linux leo-PC 5.3.0-51-generic #44~18.04.2-Ubuntu SMP Thu Apr 23 14:27:18 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

I've tried to set a static ip address but no changes.

Best Answer

I've maybe the same problem. I have:

02:00.0 Network controller: Ralink corp. RT5390 [802.11 b/g/n 1T1R G-band PCI Express Single Chip]
    Subsystem: Hewlett-Packard Company Pavilion DM1Z-3000 PCIe wireless card
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at d0100000 (32-bit, non-prefetchable) [size=64K]
    Capabilities: [40] Power Management version 3
    Capabilities: [50] MSI: Enable- Count=1/32 Maskable- 64bit+
    Capabilities: [70] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [140] Device Serial Number 00-00-9e-c4-b7-f9-55-ec
    Kernel driver in use: rt2800pci
    Kernel modules: rt2800pci

With linux-image-5.3.0-51-generic it don't work. It disconnect all the time. With linux-image-5.3.0-28-generic it works fine. Also works with all ubuntu kernels I've tested back to ubuntu 11.04 kernels.

Get this in syslog:

May 12 22:49:41 pluttis wpa_supplicant[1004]: wlan0: CTRL-EVENT-SIGNAL-CHANGE above=0 signal=-83 noise=9999 txrate=6500
May 12 22:49:45 pluttis wpa_supplicant[1004]: wlan0: SME: Trying to authenticate with 38:43:7d:60:f1:4e (SSID='JACn2G' freq=2412 MHz)
May 12 22:49:45 pluttis kernel: [  167.140512] wlan0: disconnect from AP 38:d5:47:1f:04:e0 for new auth to 38:43:7d:60:f1:4e
May 12 22:49:45 pluttis kernel: [  167.265794] wlan0: authenticate with 38:43:7d:60:f1:4e
May 12 22:49:45 pluttis kernel: [  167.268995] wlan0: send auth to 38:43:7d:60:f1:4e (try 1/3)
May 12 22:49:45 pluttis wpa_supplicant[1004]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
May 12 22:49:45 pluttis NetworkManager[953]: <info>  [1589316585.2040] device (wlan0): supplicant interface state: completed -> authenticating
May 12 22:49:45 pluttis kernel: [  167.973741] wlan0: send auth to 38:43:7d:60:f1:4e (try 2/3)
May 12 22:49:46 pluttis kernel: [  168.956007] wlan0: send auth to 38:43:7d:60:f1:4e (try 3/3)
May 12 22:49:47 pluttis kernel: [  169.356777] wlan0: authentication with 38:43:7d:60:f1:4e timed out
May 12 22:49:47 pluttis NetworkManager[953]: <info>  [1589316587.3694] device (wlan0): supplicant interface state: authenticating -> disconnected
May 12 22:49:47 pluttis NetworkManager[953]: <info>  [1589316587.4700] device (wlan0): supplicant interface state: disconnected -> scanning
May 12 22:49:47 pluttis wpa_supplicant[1004]: wlan0: SME: Trying to authenticate with 38:d5:47:1f:04:e0 (SSID='JACn2G' freq=2462 MHz)
May 12 22:49:47 pluttis kernel: [  169.601817] wlan0: authenticate with 38:d5:47:1f:04:e0
May 12 22:49:47 pluttis kernel: [  169.724194] wlan0: send auth to 38:d5:47:1f:04:e0 (try 1/3)
May 12 22:49:47 pluttis NetworkManager[953]: <info>  [1589316587.6547] device (wlan0): supplicant interface state: scanning -> authenticating
May 12 22:49:48 pluttis kernel: [  170.981842] wlan0: send auth to 38:d5:47:1f:04:e0 (try 2/3)
May 12 22:49:49 pluttis kernel: [  171.783215] wlan0: send auth to 38:d5:47:1f:04:e0 (try 3/3)
May 12 22:49:50 pluttis kernel: [  172.965891] wlan0: authentication with 38:d5:47:1f:04:e0 timed out
Related Question