Ubuntu – XPS15 fails to suspends after upgrade to ubuntu 17.10

17.10suspend

Since migrating to ubuntu 17.10 I have had some issues with suspending my system (Dell XPS15 with nvidia / intel dual graphic card)

When I press the power button briefly or call systemctl suspend, I can see that the system tries to go in suspended mode but it comes back on after a few seconds. Extracts from the syslog below

[ 2968.230422] PM: Suspending system (mem)
[ 2968.230485] Suspending console(s) (use no_console_suspend to debug)
[ 2968.439210] xhci_hcd 0000:3e:00.0: WARN: xHC CMD_RUN timeout
[ 2968.439222] suspend_common(): xhci_pci_suspend+0x0/0xd0 returns -110
[ 2968.439227] pci_pm_suspend(): hcd_pci_suspend+0x0/0x30 returns -110
[ 2968.439246] dpm_run_callback(): pci_pm_suspend+0x0/0x130 returns -110
[ 2968.439249] PM: Device 0000:3e:00.0 failed to suspend async: error -110
[ 2968.939220] thunderbolt 0000:08:00.0: Ignoring mailbox command error (-110) in icm_suspend
[ 2968.939329] PM: Some devices failed to suspend, or early wake event detected
[ 2968.939464] PM: resume of devices complete after 0.129 msecs
[ 2989.664896] PM: Finishing wakeup.
[ 2989.664899] OOM killer enabled.
[ 2989.664900] Restarting tasks ... done.

And according to lspci

3e:00.0 USB controller: Intel Corporation DSL6340 USB 3.1 Controller [Alpine Ridge] (rev ff)

Running the stock Ubuntu kernel. No special tweak

Anybody facing the same issue with a way to resolve this ?

Best Answer

  • I had similar problem. The system won't shutdown after upgrade to 17.10. I shifted to earlier stable version of kernel from grub at startup, and now everything works fine. I am currently using 4.10.0-37-generic and was facing problems on 4.13.0-16-generic