Ubuntu – Xserver error: no screens found(EE)

nvidiaxorg

I'm a newb to all of this and have no idea how to fix this problem.
I'm trying to use Xorg on ubuntu 16.04 on my AWS server by running these commands.

sudo apt-get update
sudo apt-get install -y xserver-xorg mesa-utils
sudo nvidia-xconfig -a --use-display-device=None --virtual=1280x1024

reboot and then

sudo /usr/bin/X :0 &
export DISPLAY=:0

but when I run "sudo /usr/bin/X :0 &", the error below shows

ubuntu@ip-172-31-12-99:~$ sudo /usr/bin/X :0 & [1] 1794
ubuntu@ip-172-31-12-99:~$

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-97-generic x86_64 Ubuntu
Current Operating System: Linux ip-172-31-12-99 4.4.0-1044-aws #53-Ubuntu SMP
Mon Dec 11 13:49:57 UTC 2017 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-1044-aws 
root=UUID=3e13556e-d28d-407b-bcc6-97160eafebe1 ro console=tty1 console=ttyS0
Build Date: 13 October 2017  01:57:05PM
xorg-server 2:1.18.4-0ubuntu0.7 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.33.6
Before reporting problems, check http://wiki.x.org to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jan  3 02:52:56 2018
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Fatal server error:
(EE) no screens found(EE)
(EE)
Please consult the The X.Org Foundation support at http://wiki.x.org for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.